A. M. Software Services, Inc. - Knowledge Base
Programs that connect to IP
addresses that are in the loopback address range may not work as you expect in
Windows XP Service Pack 2
SYMPTOMS
On a computer that is running Microsoft
Windows XP with Service Pack 2 (SP2), programs that connect to IP addresses that
are in the loopback address range may not work as you expect. For example, you
may receive an error message that says that you cannot establish a connection.
CAUSE
This problem occurs if the program connects to a
loopback address other than 127.0.0.1. Windows XP Service Pack 2 (SP2) prevents
connections to all IP addresses that are in the loopback address range except
for 127.0.0.1.
RESOLUTION
Hotfix information
A supported hotfix is now available from
Microsoft, but it is only intended to correct the problem that is described in
this article. Only apply it to systems that are experiencing this specific
problem. This hotfix may receive additional testing. Therefore, if you are not
severely affected by this problem, we recommend that you wait for the next
Windows XP service pack that contains this hotfix.
To resolve this
problem immediately, contact Microsoft Product Support Services to obtain the
hotfix. For a complete list of Microsoft Product Support Services phone numbers
and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Note In special cases,
charges that are ordinarily incurred for support calls may be canceled if a
Microsoft Support Professional determines that a specific update will resolve
your problem. The usual support costs will apply to additional support questions
and issues that do not qualify for the specific update in question.
Prerequisites
This hotfix requires Windows XP Service Pack
2 (SP2).
Restart requirement
You have to restart your computer after you
apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other
hotfixes.
File information
The English version of this hotfix has the
file attributes (or later) that are listed in the following table. The dates and
times for these files are listed in coordinated universal time (UTC). When you
view the file information, it is converted to local time. To find the difference
between UTC and local time, use the Time Zone tab
in the Date and Time tool in Control Panel.
Date Time Version Size File name
-----------------------------------------------------
13-Aug-2004 22:50 5.1.2600.2505 359,040 Tcpip.sys
STATUS
Microsoft has confirmed that this is a problem
in the Microsoft products that are listed in the "Applies to" section.
For additional information about how to
troubleshoot a problem where Remote Desktop Connection does not permit loopback
connections to ports that it is not listening on, click the following article
number to view the article in the Microsoft Knowledge Base:
817293 Remote
Desktop Connection does not permit loopback connections to ports that it is not
listening on
For additional information about
troubleshooting TCP/IP connectivity issues with Windows XP, click the following
article number to view the article in the Microsoft Knowledge Base:
314067 How to
troubleshoot TCP/IP connectivity with Windows XP
For additional information about
standard terminology that is used to describe Microsoft software updates, click
the following article number to view the article in the Microsoft Knowledge
Base:
824684
Description of the standard terminology that is used to describe Microsoft
software updates
The information in this
article applies to:
- Microsoft Windows XP Professional Service Pack 2 (SP2)
- Microsoft Windows XP Home Edition Service Pack 2 (SP2)
- Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
- Microsoft Windows XP Tablet PC Edition 2005
| Last Reviewed: |
8/16/2004 (1.0) |
| Keywords: |
kbQFE kb3rdparty kbprint kbnetwork
kbfix kbbug KB884020 kbAudITPRO
kbAudEndUser |