"Printer installation failed"
error message when you try to install a printer from your Web
browser
SYMPTOMS
On a Microsoft Windows 2000-based computer,
when you try to install a local intranet-based printer from your Web browser,
you receive the following error message:
Printer installation failed. You do not have
enough privilege to complete the printer installation on the local
machine.
If you log on to the computer as an
administrator or as a power user, and then you try to install the printer, you
do not receive this error message.
CAUSE
This issue may occur if the Initialize and script ActiveX controls not marked as safe
setting in Microsoft Internet Explorer is set to Enable for your local intranet. When this setting is set
to Enable, Windows tries to create an Internet
Printing Protocol (IPP) printer connection. Because an IPP printer connection
requires the installation of a local print queue, the IPP printer connection is
successful only if you are logged on as an administrator or as a power user. If
you are logged on as a typical user, the IPP printer connection fails because
your permissions are not sufficient.
Note This issue
occurs in both Microsoft Internet Explorer 5.5 Service Pack 2 (SP2) and Internet
Explorer 6.0 Service Pack 1 (SP1).
RESOLUTION
Hotfix information
A supported hotfix is now available from
Microsoft, but it is only intended to correct the problem that is described in
this article. Only apply it to systems that are experiencing this specific
problem. This hotfix may receive additional testing. Therefore, if you are not
severely affected by this problem, Microsoft recommends that you wait for the
next Windows 2000 service pack that contains this hotfix.
To resolve this
problem immediately, contact Microsoft Product Support Services to obtain the
hotfix. For a complete list of Microsoft Product Support Services phone numbers
and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Note In special cases,
charges that are ordinarily incurred for support calls may be canceled if a
Microsoft Support Professional determines that a specific update will resolve
your problem. The usual support costs will apply to additional support questions
and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you
apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other
hotfixes.
File information
The English version of this hotfix has the
file attributes (or later) that are listed in the following table. The dates and
times for these files are listed in coordinated universal time (UTC). When you
view the file information, it is converted to local time. To find the difference
between UTC and local time, use the Time Zone tab
in the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------------
27-Aug-2003 20:57 5.0.2195.6811 106,256 Oleprn.dll
STATUS
Microsoft has confirmed that this is a problem
in the Microsoft products that are listed in the "Applies to" section of this
article.
When the Initialize and script ActiveX controls not marked as safe
setting for the local intranet is set to Disable
or to Prompt, Windows creates a remote procedure
call (RPC) printer connection when you try to connect to an intranet-based
printer through your Web browser. In this scenario, printer installations are
successful for both users and administrators because RPC printer connections use
the Windows remote spooler.
To locate the Initialize and script ActiveX controls not marked as safe
setting, follow these steps:
For more information about Web-based printing, visit the
following Microsoft Web site to view the "Printer Connectivity Technical
Overview" white paper:
http://www.microsoft.com/windowsserver2003/techinfo/overview/connectivity.mspx
For additional information about how hotfix packages are
named, click the following article number to view the article in the Microsoft
Knowledge Base:
816915 New file
naming schema for Microsoft Windows software update packages
For additional information, click the following article
number to view the article in the Microsoft Knowledge Base:
824684
Description of the standard terminology that is used to describe Microsoft
software updates
The information in this
article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
| Last Reviewed: |
2/11/2004 (1.0) |
| Keywords: |
kberrmsg kbBug kbfix kbQFE kbWin2000preSP5fix KB826978
kbAudITPRO
|